#/bin/bash или Zoomaster ...или кое е общото

"Земята на Гошо" под Debian 6.0... или инсталиране на Google Earth в Debian Squeeze
  
Вторник, 14 Декември 2010г. 20:43ч.

Google Earth под Debian

Вчера ми се наложи да инсталирам на една клиентска машина с Debian Squeeze "Земята на Гошо", по известна като Google Earth. По някакви непонятни за мен причини, въпреки адекватната корекция на зависимостите, инсталатора предоставян от Google продължаваше да се "троши" изкарвайки грешка при намирането или прочитането на data/setup.xml. Четенето по различни форуми и блогове (включително и официалния на Google Earth)  показа едно - не е било само при мен тъй. Даже срещнах мнениия от типа "Спред мен Google Earth не работи и няма да работи на Debian Squeeze!". Аз нали съм си инат обаче, си компилирах пакета сам с помощта на един простичък инструмент и воала - работи, лесно е за инсталация и лесно се коригират зависимостите. Как се прави:

1. Теглите си подходящия пакет за вашата архитектура:

Google Earth за Debian (Ubuntu) - 64 bit

Google Earth за Debian (Ubuntu) - 32 bit

2. Изпълнявате

# dpkg - i googleearth_6.0.0.1735+0.6.0-1_i386.deb или

# dpkg - i googleearth_6.0.0.1735+0.6.0-1_amd64.deb

3. Коригирате зависимостите с

#apt-get -f install

4. Инсталирате си гадните микромеки шрифтове ("Земята на Гошо" ползва тях за интерфейса си)

#apt-get install ttf-mscorefonts-installer

5. Готови сте!

П.П. Ако нещо не работи както трябва - обаждайте се! Пакетите са компилирани от мен и са тествани само на 4 машини.

 

Коментари  

 
-4 #1 Анонимен 2010-12-17 17:30
Инсталатора на Google Earth не работи и в Ubuntu 10.10.
Твоите команди не работят също!

reyhan@laptop-reyhan:~$ dpkg -i googleearth_6.0.0.1735+0.6.0-1_i386.deb
dpkg: requested operation requires superuser privilege
Цитиране | Докладвай на администратор
 
 
+2 #2 #/bin/bash 2010-12-17 18:01
За Ubuntu слагайте по едно sudo пред командите. Трябва да са с административни права все пак :-)
Цитиране | Докладвай на администратор
 
 
-1 #3 ikni 2010-12-21 01:59
Ако не държиш да е версия 6, може да добавш долния ред в sources.list-а:
deb packages.linuxmint.com/ debian main upstream import
Тук може да зачетеш нещо което може би ти е убягнало:
blog.linuxmint.com/?p=1527
"2. Is LMDE fully compatible with Debian?
Yes, 100%. LMDE is compatible with repositories designed for Debian Testing or Debian Squeeze."
Цитиране | Докладвай на администратор
 

Добави коментар


Защитен код
Обнови

Моята фирма

Зоовет трейдинг

Абонирай се!

Абонирай се за целия блог!

Абонирай се само за Open Source статии!

Абонирай се само за ветеринарни статии!